.TH "rte_meter.h" 3 "Version 25.11.0" "DPDK" \" -*- nroff -*-
.ad l
.nh
.SH NAME
rte_meter.h
.SH SYNOPSIS
.br
.PP
\fR#include <stdint\&.h>\fP
.br

.SS "Data Structures"

.in +1c
.ti -1c
.RI "struct \fBrte_meter_srtcm_params\fP"
.br
.ti -1c
.RI "struct \fBrte_meter_trtcm_params\fP"
.br
.ti -1c
.RI "struct \fBrte_meter_trtcm_rfc4115_params\fP"
.br
.ti -1c
.RI "struct \fBrte_meter_trtcm\fP"
.br
.ti -1c
.RI "struct \fBrte_meter_trtcm_rfc4115\fP"
.br
.in -1c
.SS "Enumerations"

.in +1c
.ti -1c
.RI "enum \fBrte_color\fP { \fBRTE_COLOR_GREEN\fP = 0, \fBRTE_COLOR_YELLOW\fP, \fBRTE_COLOR_RED\fP, \fBRTE_COLORS\fP }"
.br
.in -1c
.SS "Functions"

.in +1c
.ti -1c
.RI "int \fBrte_meter_srtcm_profile_config\fP (struct rte_meter_srtcm_profile *p, struct \fBrte_meter_srtcm_params\fP *params)"
.br
.ti -1c
.RI "int \fBrte_meter_trtcm_profile_config\fP (struct rte_meter_trtcm_profile *p, struct \fBrte_meter_trtcm_params\fP *params)"
.br
.ti -1c
.RI "int \fBrte_meter_trtcm_rfc4115_profile_config\fP (struct rte_meter_trtcm_rfc4115_profile *p, struct \fBrte_meter_trtcm_rfc4115_params\fP *params)"
.br
.ti -1c
.RI "int \fBrte_meter_srtcm_config\fP (struct rte_meter_srtcm *m, struct rte_meter_srtcm_profile *p)"
.br
.ti -1c
.RI "int \fBrte_meter_trtcm_config\fP (struct \fBrte_meter_trtcm\fP *m, struct rte_meter_trtcm_profile *p)"
.br
.ti -1c
.RI "int \fBrte_meter_trtcm_rfc4115_config\fP (struct \fBrte_meter_trtcm_rfc4115\fP *m, struct rte_meter_trtcm_rfc4115_profile *p)"
.br
.ti -1c
.RI "static enum \fBrte_color\fP \fBrte_meter_srtcm_color_blind_check\fP (struct rte_meter_srtcm *m, struct rte_meter_srtcm_profile *p, uint64_t time, uint32_t pkt_len)"
.br
.ti -1c
.RI "static enum \fBrte_color\fP \fBrte_meter_srtcm_color_aware_check\fP (struct rte_meter_srtcm *m, struct rte_meter_srtcm_profile *p, uint64_t time, uint32_t pkt_len, enum \fBrte_color\fP pkt_color)"
.br
.ti -1c
.RI "static enum \fBrte_color\fP \fBrte_meter_trtcm_color_blind_check\fP (struct \fBrte_meter_trtcm\fP *m, struct rte_meter_trtcm_profile *p, uint64_t time, uint32_t pkt_len)"
.br
.ti -1c
.RI "static enum \fBrte_color\fP \fBrte_meter_trtcm_color_aware_check\fP (struct \fBrte_meter_trtcm\fP *m, struct rte_meter_trtcm_profile *p, uint64_t time, uint32_t pkt_len, enum \fBrte_color\fP pkt_color)"
.br
.ti -1c
.RI "static enum \fBrte_color\fP \fBrte_meter_trtcm_rfc4115_color_blind_check\fP (struct \fBrte_meter_trtcm_rfc4115\fP *m, struct rte_meter_trtcm_rfc4115_profile *p, uint64_t time, uint32_t pkt_len)"
.br
.ti -1c
.RI "static enum \fBrte_color\fP \fBrte_meter_trtcm_rfc4115_color_aware_check\fP (struct \fBrte_meter_trtcm_rfc4115\fP *m, struct rte_meter_trtcm_rfc4115_profile *p, uint64_t time, uint32_t pkt_len, enum \fBrte_color\fP pkt_color)"
.br
.in -1c
.SH "Detailed Description"
.PP 
RTE Traffic Metering

.PP
Traffic metering algorithms:
.IP "1." 4
Single Rate Three Color Marker (srTCM): defined by IETF RFC 2697
.IP "2." 4
Two Rate Three Color Marker (trTCM): defined by IETF RFC 2698
.IP "3." 4
Two Rate Three Color Marker (trTCM): defined by IETF RFC 4115 
.PP

.PP
Definition in file \fBrte_meter\&.h\fP\&.
.SH "Enumeration Type Documentation"
.PP 
.SS "enum \fBrte_color\fP"
Color 
.PP
\fBEnumerator\fP
.in +1c
.TP
\f(BIRTE_COLOR_GREEN \fP
Green 
.TP
\f(BIRTE_COLOR_YELLOW \fP
Yellow 
.TP
\f(BIRTE_COLOR_RED \fP
Red 
.TP
\f(BIRTE_COLORS \fP
Number of colors 
.PP
Definition at line \fB31\fP of file \fBrte_meter\&.h\fP\&.
.SH "Function Documentation"
.PP 
.SS "int rte_meter_srtcm_profile_config (struct rte_meter_srtcm_profile * p, struct \fBrte_meter_srtcm_params\fP * params)"
srTCM profile configuration

.PP
\fBParameters\fP
.RS 4
\fIp\fP Pointer to pre-allocated srTCM profile data structure 
.br
\fIparams\fP srTCM profile parameters 
.RE
.PP
\fBReturns\fP
.RS 4
0 upon success, error code otherwise 
.RE
.PP

.SS "int rte_meter_trtcm_profile_config (struct rte_meter_trtcm_profile * p, struct \fBrte_meter_trtcm_params\fP * params)"
trTCM profile configuration

.PP
\fBParameters\fP
.RS 4
\fIp\fP Pointer to pre-allocated trTCM profile data structure 
.br
\fIparams\fP trTCM profile parameters 
.RE
.PP
\fBReturns\fP
.RS 4
0 upon success, error code otherwise 
.RE
.PP

.SS "int rte_meter_trtcm_rfc4115_profile_config (struct rte_meter_trtcm_rfc4115_profile * p, struct \fBrte_meter_trtcm_rfc4115_params\fP * params)"
trTCM RFC 4115 profile configuration

.PP
\fBParameters\fP
.RS 4
\fIp\fP Pointer to pre-allocated trTCM profile data structure 
.br
\fIparams\fP trTCM profile parameters 
.RE
.PP
\fBReturns\fP
.RS 4
0 upon success, error code otherwise 
.RE
.PP

.SS "int rte_meter_srtcm_config (struct rte_meter_srtcm * m, struct rte_meter_srtcm_profile * p)"
srTCM configuration per metered traffic flow

.PP
\fBParameters\fP
.RS 4
\fIm\fP Pointer to pre-allocated srTCM data structure 
.br
\fIp\fP srTCM profile\&. Needs to be valid\&. 
.RE
.PP
\fBReturns\fP
.RS 4
0 upon success, error code otherwise 
.RE
.PP

.SS "int rte_meter_trtcm_config (struct \fBrte_meter_trtcm\fP * m, struct rte_meter_trtcm_profile * p)"
trTCM configuration per metered traffic flow

.PP
\fBParameters\fP
.RS 4
\fIm\fP Pointer to pre-allocated trTCM data structure 
.br
\fIp\fP trTCM profile\&. Needs to be valid\&. 
.RE
.PP
\fBReturns\fP
.RS 4
0 upon success, error code otherwise 
.RE
.PP

.SS "int rte_meter_trtcm_rfc4115_config (struct \fBrte_meter_trtcm_rfc4115\fP * m, struct rte_meter_trtcm_rfc4115_profile * p)"
trTCM RFC 4115 configuration per metered traffic flow

.PP
\fBParameters\fP
.RS 4
\fIm\fP Pointer to pre-allocated trTCM data structure 
.br
\fIp\fP trTCM profile\&. Needs to be valid\&. 
.RE
.PP
\fBReturns\fP
.RS 4
0 upon success, error code otherwise 
.RE
.PP

.SS "enum \fBrte_color\fP rte_meter_srtcm_color_blind_check (struct rte_meter_srtcm * m, struct rte_meter_srtcm_profile * p, uint64_t time, uint32_t pkt_len)\fR [inline]\fP, \fR [static]\fP"
srTCM color blind traffic metering

.PP
\fBParameters\fP
.RS 4
\fIm\fP Handle to srTCM instance 
.br
\fIp\fP srTCM profile specified at srTCM object creation time 
.br
\fItime\fP Current CPU time stamp (measured in CPU cycles) 
.br
\fIpkt_len\fP Length of the current IP packet (measured in bytes) 
.RE
.PP
\fBReturns\fP
.RS 4
Color assigned to the current IP packet 
.RE
.PP

.PP
Definition at line \fB396\fP of file \fBrte_meter\&.h\fP\&.
.SS "enum \fBrte_color\fP rte_meter_srtcm_color_aware_check (struct rte_meter_srtcm * m, struct rte_meter_srtcm_profile * p, uint64_t time, uint32_t pkt_len, enum \fBrte_color\fP pkt_color)\fR [inline]\fP, \fR [static]\fP"
srTCM color aware traffic metering

.PP
\fBParameters\fP
.RS 4
\fIm\fP Handle to srTCM instance 
.br
\fIp\fP srTCM profile specified at srTCM object creation time 
.br
\fItime\fP Current CPU time stamp (measured in CPU cycles) 
.br
\fIpkt_len\fP Length of the current IP packet (measured in bytes) 
.br
\fIpkt_color\fP Input color of the current IP packet 
.RE
.PP
\fBReturns\fP
.RS 4
Color assigned to the current IP packet 
.RE
.PP

.PP
Definition at line \fB437\fP of file \fBrte_meter\&.h\fP\&.
.SS "enum \fBrte_color\fP rte_meter_trtcm_color_blind_check (struct \fBrte_meter_trtcm\fP * m, struct rte_meter_trtcm_profile * p, uint64_t time, uint32_t pkt_len)\fR [inline]\fP, \fR [static]\fP"
trTCM color blind traffic metering

.PP
\fBParameters\fP
.RS 4
\fIm\fP Handle to trTCM instance 
.br
\fIp\fP trTCM profile specified at trTCM object creation time 
.br
\fItime\fP Current CPU time stamp (measured in CPU cycles) 
.br
\fIpkt_len\fP Length of the current IP packet (measured in bytes) 
.RE
.PP
\fBReturns\fP
.RS 4
Color assigned to the current IP packet 
.RE
.PP

.PP
Definition at line \fB479\fP of file \fBrte_meter\&.h\fP\&.
.SS "enum \fBrte_color\fP rte_meter_trtcm_color_aware_check (struct \fBrte_meter_trtcm\fP * m, struct rte_meter_trtcm_profile * p, uint64_t time, uint32_t pkt_len, enum \fBrte_color\fP pkt_color)\fR [inline]\fP, \fR [static]\fP"
trTCM color aware traffic metering

.PP
\fBParameters\fP
.RS 4
\fIm\fP Handle to trTCM instance 
.br
\fIp\fP trTCM profile specified at trTCM object creation time 
.br
\fItime\fP Current CPU time stamp (measured in CPU cycles) 
.br
\fIpkt_len\fP Length of the current IP packet (measured in bytes) 
.br
\fIpkt_color\fP Input color of the current IP packet 
.RE
.PP
\fBReturns\fP
.RS 4
Color assigned to the current IP packet 
.RE
.PP

.PP
Definition at line \fB521\fP of file \fBrte_meter\&.h\fP\&.
.SS "enum \fBrte_color\fP rte_meter_trtcm_rfc4115_color_blind_check (struct \fBrte_meter_trtcm_rfc4115\fP * m, struct rte_meter_trtcm_rfc4115_profile * p, uint64_t time, uint32_t pkt_len)\fR [inline]\fP, \fR [static]\fP"
trTCM RFC4115 color blind traffic metering

.PP
\fBParameters\fP
.RS 4
\fIm\fP Handle to trTCM instance 
.br
\fIp\fP trTCM profile specified at trTCM object creation time 
.br
\fItime\fP Current CPU time stamp (measured in CPU cycles) 
.br
\fIpkt_len\fP Length of the current IP packet (measured in bytes) 
.RE
.PP
\fBReturns\fP
.RS 4
Color assigned to the current IP packet 
.RE
.PP

.PP
Definition at line \fB564\fP of file \fBrte_meter\&.h\fP\&.
.SS "enum \fBrte_color\fP rte_meter_trtcm_rfc4115_color_aware_check (struct \fBrte_meter_trtcm_rfc4115\fP * m, struct rte_meter_trtcm_rfc4115_profile * p, uint64_t time, uint32_t pkt_len, enum \fBrte_color\fP pkt_color)\fR [inline]\fP, \fR [static]\fP"
trTCM RFC4115 color aware traffic metering

.PP
\fBParameters\fP
.RS 4
\fIm\fP Handle to trTCM instance 
.br
\fIp\fP trTCM profile specified at trTCM object creation time 
.br
\fItime\fP Current CPU time stamp (measured in CPU cycles) 
.br
\fIpkt_len\fP Length of the current IP packet (measured in bytes) 
.br
\fIpkt_color\fP Input color of the current IP packet 
.RE
.PP
\fBReturns\fP
.RS 4
Color assigned to the current IP packet 
.RE
.PP

.PP
Definition at line \fB607\fP of file \fBrte_meter\&.h\fP\&.
.SH "Author"
.PP 
Generated automatically by Doxygen for DPDK from the source code\&.
