URTWN(4) | Device Drivers Manual | URTWN(4) |
NAME¶
urtwn
— Realtek
RTL8188CU/RTL8188RU/RTL8188EU/RTL8192CU USB IEEE 802.11b/g/n wireless
network device
SYNOPSIS¶
options URTWN_WITHOUT_UCODE
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device ehci
device uhci
device ohci
device usb
device urtwn
device wlan
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
if_urtwn_load="YES"
DESCRIPTION¶
The urtwn
driver supports USB 2.0 wireless
network devices based on Realtek RTL8188CUS, RTL8188CE-VAU, RTL8188EUS,
RTL8188RU and RTL8192CU chipsets.
The RTL8188CUS and RTL8188EUS are highly integrated 802.11n adapters that combine a MAC, a 1T1R capable baseband and an RF in a single chip. They operate in the 2GHz spectrum only. The RTL8188RU is a high-power variant of the RTL8188CUS. The RTL8188CE-VAU is a PCI Express Mini Card adapter that attaches to the USB interface.
The RTL8192CU is a highly integrated multiple-in, multiple-out (MIMO) 802.11n adapter that combines a MAC, a 2T2R capable baseband and an RF in a single chip. It operates in the 2GHz spectrum only.
All chips have hardware support for WEP, AES-CCM and TKIP encryption.
The driver supports station
,
adhoc
, hostap
, and
monitor
mode operation. Only one virtual interface
may be configured at any time.
This driver may use the firmware built with the
urtwnfw
module for some additional features (when
URTWN_WITHOUT_UCODE kernel option is not set).
FILES¶
- /usr/share/doc/legal/realtek.LICENSE
urtwn
firmware license
HARDWARE¶
The urtwn
driver supports Realtek
RTL8188CU/RTL8188RU/RTL8188EU/RTL8192CU based USB IEEE 802.11b/g/n wireless
network adapters, including:
- Alfa AWUS036NHR v2
- ASUS USB-N10 NANO
- Belkin F7D1102 Surf Wireless Micro
- D-Link DWA-123 rev D1
- D-Link DWA-125 rev D1
- D-Link DWA-131
- Edimax EW-7811Un
- Elecom WDC-150SU2M
- Netgear WNA1000M
- Realtek RTL8192CU
- Realtek RTL8188CUS
- TP-LINK TL-WN723N v3
- TP-LINK TL-WN725N v2
EXAMPLES¶
Join an existing BSS network (i.e., connect to an access point):
ifconfig wlan create wlandev urtwn0 inet 192.168.0.20 \ netmask 0xffffff00
Join a specific BSS network with network name
“my_net
”:
ifconfig wlan create wlandev urtwn0
ssid my_net up
Join a specific BSS network with 64-bit WEP encryption:
ifconfig wlan create wlandev urtwn0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up
Create an IBSS network with 128-bit WEP encryption on the channel 4:
ifconfig wlan0 create wlandev urtwn0 wlanmode adhoc ssid my_net \ wepmode on wepkey 0x01020304050607080910111213 weptxkey 1 \ channel 4
Join/create an 802.11b IBSS network with network name
“my_net
”:
ifconfig wlan0 create wlandev urtwn0 wlanmode adhoc ifconfig wlan0 inet 192.168.0.22 netmask 0xffffff00 ssid my_net \ mode 11b
Create an 802.11g host-based access point:
ifconfig wlan0 create wlandev urtwn0 wlanmode hostap ifconfig wlan0 inet 192.168.0.10 netmask 0xffffff00 ssid my_ap \ mode 11g
DIAGNOSTICS¶
- urtwn%d: error %d, could not read firmware %s
- For some reason, the driver was unable to read the microcode file from the filesystem. The file might be missing or corrupted.
- urtwn%d: device timeout
- A frame dispatched to the hardware for transmission did not complete in time. The driver will reset the hardware. This should not happen.
SEE ALSO¶
intro(4), netintro(4), urtwnfw(4), usb(4), wlan(4), wlan_amrr(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), ifconfig(8), wpa_supplicant(8)
Realtek, http://www.realtek.com.tw.
HISTORY¶
The urtwn
driver first appeared in
OpenBSD 4.9 and FreeBSD
10.0.
AUTHORS¶
The urtwn
driver was written by
Damien Bergamini
<damien@openbsd.org>.
CAVEATS¶
The urtwn
driver currently does not
support A-MPDU 802.11n transmit aggregation.
For non-RTL8188EUS chips “rate control” algorithm is absent; this may result in increased packet loss in noisy networks.
June 9, 2016 | Debian |