table of contents
CRYPTO(9) | Kernel Developer's Manual | CRYPTO(9) |
NAME¶
crypto
— API for
cryptographic services in the kernel
SYNOPSIS¶
#include
<opencrypto/cryptodev.h>
int32_t
crypto_get_driverid
(device_t
dev, size_t
session_size, int
flags);
int
crypto_register
(uint32_t
driverid, int alg,
uint16_t maxoplen,
uint32_t flags);
int
crypto_kregister
(uint32_t
driverid, int kalg,
uint32_t flags);
int
crypto_unregister
(uint32_t
driverid, int
alg);
int
crypto_unregister_all
(uint32_t
driverid);
void
crypto_done
(struct
cryptop *crp);
void
crypto_kdone
(struct
cryptkop *krp);
int
crypto_find_driver
(const
char *match);
int
crypto_newsession
(crypto_session_t
*cses, struct cryptoini
*cri, int
crid);
int
crypto_freesession
(crypto_session_t
cses);
int
crypto_dispatch
(struct
cryptop *crp);
int
crypto_kdispatch
(struct
cryptkop *krp);
int
crypto_unblock
(uint32_t
driverid, int
what);
struct cryptop *
crypto_getreq
(int
num);
void
crypto_freereq
(struct
cryptop *crp);
#define CRYPTO_SYMQ 0x1 #define CRYPTO_ASYMQ 0x2 #define EALG_MAX_BLOCK_LEN 16 struct cryptoini { int cri_alg; int cri_klen; int cri_mlen; caddr_t cri_key; uint8_t cri_iv[EALG_MAX_BLOCK_LEN]; struct cryptoini *cri_next; }; struct cryptodesc { int crd_skip; int crd_len; int crd_inject; int crd_flags; struct cryptoini CRD_INI; #define crd_iv CRD_INI.cri_iv #define crd_key CRD_INI.cri_key #define crd_alg CRD_INI.cri_alg #define crd_klen CRD_INI.cri_klen struct cryptodesc *crd_next; }; struct cryptop { TAILQ_ENTRY(cryptop) crp_next; crypto_session_t crp_session; int crp_ilen; int crp_olen; int crp_etype; int crp_flags; caddr_t crp_buf; caddr_t crp_opaque; struct cryptodesc *crp_desc; int (*crp_callback) (struct cryptop *); caddr_t crp_mac; }; struct crparam { caddr_t crp_p; u_int crp_nbits; }; #define CRK_MAXPARAM 8 struct cryptkop { TAILQ_ENTRY(cryptkop) krp_next; u_int krp_op; /* ie. CRK_MOD_EXP or other */ u_int krp_status; /* return status */ u_short krp_iparams; /* # of input parameters */ u_short krp_oparams; /* # of output parameters */ uint32_t krp_hid; struct crparam krp_param[CRK_MAXPARAM]; int (*krp_callback)(struct cryptkop *); };
DESCRIPTION¶
crypto
is a framework for drivers of
cryptographic hardware to register with the kernel so
“consumers” (other kernel subsystems, and users through the
/dev/crypto device) are able to make use of it.
Drivers register with the framework the algorithms they support, and provide
entry points (functions) the framework may call to establish, use, and tear
down sessions. Sessions are used to cache cryptographic information in a
particular driver (or associated hardware), so initialization is not needed
with every request. Consumers of cryptographic services pass a set of
descriptors that instruct the framework (and the drivers registered with it)
of the operations that should be applied on the data (more than one
cryptographic operation can be requested).
Keying operations are supported as well. Unlike the symmetric operators described above, these sessionless commands perform mathematical operations using input and output parameters.
Since the consumers may not be associated with a process, drivers
may not sleep(9). The same holds for the framework. Thus,
a callback mechanism is used to notify a consumer that a request has been
completed (the callback is specified by the consumer on a per-request
basis). The callback is invoked by the framework whether the request was
successfully completed or not. An error indication is provided in the latter
case. A specific error code, EAGAIN
, is used to
indicate that a session handle has changed and that the request may be
re-submitted immediately with the new session. Errors are only returned to
the invoking function if not enough information to call the callback is
available (meaning, there was a fatal error in verifying the arguments). For
session initialization and teardown no callback mechanism is used.
The
crypto_find_driver
()
returns the driver id of the device whose name matches
match. match can either be the
exact name of a device including the unit or the driver name without a unit.
In the latter case, the id of the first device with the matching driver name
is returned. If no matching device is found, the value -1 is returned.
The
crypto_newsession
()
routine is called by consumers of cryptographic services (such as the
ipsec(4) stack) that wish to establish a new session with
the framework. The cri argument points to a
cryptoini structure containing all the necessary
information for the driver to establish the session. The
crid argument is either a specific driver id or a
bitmask of flags. The flags are
CRYPTOCAP_F_HARDWARE
, to select hardware devices, or
CRYPTOCAP_F_SOFTWARE
, to select software devices. If
both are specified, hardware devices are preferred over software devices. On
success, the opaque session handle of the new session will be stored in
*cses. The cryptoini structure
pointed to by cri contains these fields:
- cri_alg
- An algorithm identifier. Currently supported algorithms are:
CRYPTO_AES_128_NIST_GMAC
CRYPTO_AES_192_NIST_GMAC
CRYPTO_AES_256_NIST_GMAC
CRYPTO_AES_CBC
CRYPTO_AES_CCM_16
CRYPTO_AES_CCM_CBC_MAC
CRYPTO_AES_ICM
CRYPTO_AES_NIST_GCM_16
CRYPTO_AES_NIST_GMAC
CRYPTO_AES_XTS
CRYPTO_ARC4
CRYPTO_BLAKE2B
CRYPTO_BLAKE2S
CRYPTO_BLF_CBC
CRYPTO_CAMELLIA_CBC
CRYPTO_CAST_CBC
CRYPTO_CHACHA20
CRYPTO_DEFLATE_COMP
CRYPTO_DES_CBC
CRYPTO_3DES_CBC
CRYPTO_MD5
CRYPTO_MD5_HMAC
CRYPTO_MD5_KPDK
CRYPTO_NULL_HMAC
CRYPTO_NULL_CBC
CRYPTO_POLY1305
CRYPTO_RIPEMD160
CRYPTO_RIPEMD160_HMAC
CRYPTO_SHA1
CRYPTO_SHA1_HMAC
CRYPTO_SHA1_KPDK
CRYPTO_SHA2_224
CRYPTO_SHA2_224_HMAC
CRYPTO_SHA2_256
CRYPTO_SHA2_256_HMAC
CRYPTO_SHA2_384
CRYPTO_SHA2_384_HMAC
CRYPTO_SHA2_512
CRYPTO_SHA2_512_HMAC
CRYPTO_SKIPJACK_CBC
- cri_klen
- For variable-size key algorithms, the length of the key in bits.
- cri_mlen
- If non-zero, truncate the calculated hash to this many bytes.
- cri_key
- The key to be used.
- cri_iv
- An explicit initialization vector if it does not prefix the data. This
field is ignored during initialization
(
crypto_newsession
). If no IV is explicitly passed (see below on details), a random IV is used by the device driver processing the request. - cri_next
- Pointer to another cryptoini structure. This is used to establish dual-algorithm sessions, such as combining a cipher with a MAC.
The cryptoini
structure and its contents will not be modified or referenced by the
framework or any cryptographic drivers. The memory associated with
cri can be released once
crypto_newsession
()
returns.
crypto_freesession
()
is called with the session handle returned by
crypto_newsession
() to free the session.
crypto_dispatch
()
is called to process a request. The various fields in the
cryptop structure are:
- crp_session
- The session handle.
- crp_ilen
- The total length in bytes of the buffer to be processed.
- crp_olen
- On return, contains the total length of the result. For symmetric crypto operations, this will be the same as the input length. This will be used if the framework needs to allocate a new buffer for the result (or for re-formatting the input).
- crp_callback
- Callback routine invoked when a request is completed via
crypto_done
(). The callback routine should inspect the crp_etype to determine if the request was successfully completed. - crp_etype
- The error type, if any errors were encountered, or zero if the request was
successfully processed. If the
EAGAIN
error code is returned, the session handle has changed (and has been recorded in the crp_session field). The consumer should record the new session handle and use it in all subsequent requests. In this case, the request may be re-submitted immediately. This mechanism is used by the framework to perform session migration (move a session from one driver to another, because of availability, performance, or other considerations).This field is only valid in the context of the callback routine specified by crp_callback. Errors are returned to the invoker of
crypto_process
() only when enough information is not present to call the callback routine (i.e., if the pointer passed isNULL
or if no callback routine was specified). - crp_flags
- A bitmask of flags associated with this request. Currently defined flags
are:
CRYPTO_F_IMBUF
- The buffer is an mbuf chain pointed to by crp_mbuf.
CRYPTO_F_IOV
- The buffer is a uio structure pointed to by crp_uio.
CRYPTO_F_BATCH
- Batch operation if possible.
CRYPTO_F_CBIMM
- Do callback immediately instead of doing it from a dedicated kernel thread.
CRYPTO_F_DONE
- Operation completed.
CRYPTO_F_CBIFSYNC
- Do callback immediately if operation is synchronous (that the driver
specified the
CRYPTOCAP_F_SYNC
flag). CRYPTO_F_ASYNC
- Try to do the crypto operation in a pool of workers if the operation
is synchronous (that is, if the driver specified the
CRYPTOCAP_F_SYNC
flag). It aims to speed up processing by dispatching crypto operations on different processors. CRYPTO_F_ASYNC_KEEPORDER
- Dispatch callbacks in the same order they are posted. Only relevant if
the
CRYPTO_F_ASYNC
flag is set and if the operation is synchronous.
- crp_buf
- Data buffer unless
CRYPTO_F_IMBUF
orCRYPTO_F_IOV
is set in crp_flags. The length in bytes is set in crp_ilen. - crp_mbuf
- Data buffer mbuf chain when
CRYPTO_F_IMBUF
is set in crp_flags. - crp_uio
- struct uio data buffer when
CRYPTO_F_IOV
is set in crp_flags. - crp_opaque
- Cookie passed through the crypto framework untouched. It is intended for the invoking application's use.
- crp_desc
- A linked list of descriptors. Each descriptor provides information about
what type of cryptographic operation should be done on the input buffer.
The various fields are:
- crd_iv
- When the flag
CRD_F_IV_EXPLICIT
is set, this field contains the IV. - crd_key
- When the
CRD_F_KEY_EXPLICIT
flag is set, the crd_key points to a buffer with encryption or authentication key. - crd_alg
- An algorithm to use. Must be the same as the one given at newsession time.
- crd_klen
- The crd_key key length.
- crd_skip
- The offset in the input buffer where processing should start.
- crd_len
- How many bytes, after crd_skip, should be processed.
- crd_inject
- The crd_inject field specifies an offset in bytes from the beginning of the buffer. For encryption algorithms, this may be where the IV will be inserted when encrypting or where the IV may be found for decryption (subject to crd_flags). For MAC algorithms, this is where the result of the keyed hash will be inserted.
- crd_flags
- The following flags are defined:
CRD_F_ENCRYPT
- For encryption algorithms, this bit is set when encryption is required (when not set, decryption is performed).
CRD_F_IV_PRESENT
- For encryption, if this bit is not set the IV used to encrypt the
packet will be written at the location pointed to by
crd_inject. The IV length is assumed to be
equal to the blocksize of the encryption algorithm. For
encryption, if this bit is set, nothing is done. For decryption,
this flag has no meaning. Applications that do special “IV
cooking”, such as the half-IV mode in
ipsec(4), can use this flag to indicate that the
IV should not be written on the packet. This flag is typically
used in conjunction with the
CRD_F_IV_EXPLICIT
flag. CRD_F_IV_EXPLICIT
- This bit is set when the IV is explicitly provided by the consumer in the crd_iv field. Otherwise, for encryption operations the IV is provided for by the driver used to perform the operation, whereas for decryption operations the offset of the IV is provided by the crd_inject field. This flag is typically used when the IV is calculated “on the fly” by the consumer, and does not precede the data.
CRD_F_KEY_EXPLICIT
- For encryption and authentication (MAC) algorithms, this bit is set when the key is explicitly provided by the consumer in the crd_key field for the given operation. Otherwise, the key is taken at newsession time from the cri_key field. As calculating the key schedule may take a while, it is recommended that often used keys are given their own session.
CRD_F_COMP
- For compression algorithms, this bit is set when compression is required (when not set, decompression is performed).
- CRD_INI
- This cryptoini structure will not be modified by the framework or the device drivers. Since this information accompanies every cryptographic operation request, drivers may re-initialize state on-demand (typically an expensive operation). Furthermore, the cryptographic framework may re-route requests as a result of full queues or hardware failure, as described above.
- crd_next
- Point to the next descriptor. Linked operations are useful in protocols such as ipsec(4), where multiple cryptographic transforms may be applied on the same block of data.
crypto_getreq
()
allocates a cryptop structure with a linked list of
num cryptodesc structures.
crypto_freereq
()
deallocates a structure cryptop and any
cryptodesc structures linked to it. Note that it is
the responsibility of the callback routine to do the necessary cleanups
associated with the opaque field in the cryptop
structure.
crypto_kdispatch
()
is called to perform a keying operation. The various fields in the
cryptkop structure are:
- krp_op
- Operation code, such as
CRK_MOD_EXP
. - krp_status
- Return code. This errno-style variable indicates whether lower level reasons for operation failure.
- krp_iparams
- Number of input parameters to the specified operation. Note that each operation has a (typically hardwired) number of such parameters.
- krp_oparams
- Number of output parameters from the specified operation. Note that each operation has a (typically hardwired) number of such parameters.
- krp_kvp
- An array of kernel memory blocks containing the parameters.
- krp_hid
- Identifier specifying which low-level driver is being used.
- krp_callback
- Callback called on completion of a keying operation.
DRIVER-SIDE API¶
The crypto_get_driverid
(),
crypto_get_driver_session
(),
crypto_register
(),
crypto_kregister
(),
crypto_unregister
(),
crypto_unblock
(), and
crypto_done
() routines are used by drivers that
provide support for cryptographic primitives to register and unregister with
the kernel crypto services framework.
Drivers must first use the
crypto_get_driverid
()
function to acquire a driver identifier, specifying the
flags as an argument. One of
CRYPTOCAP_F_SOFTWARE
or
CRYPTOCAP_F_HARDWARE
must be specified. The
CRYPTOCAP_F_SYNC
may also be specified, and should
be specified if the driver does all of it's operations synchronously.
Drivers must pass the size of their session structure as the second
argument. An appropriately sized memory will be allocated by the framework,
zeroed, and passed to the driver's
newsession
()
method.
For each algorithm the driver supports, it
must then call
crypto_register
().
The first two arguments are the driver and algorithm identifiers. The next
two arguments specify the largest possible operator length (in bits,
important for public key operations) and flags for this algorithm.
crypto_unregister
()
is called by drivers that wish to withdraw support for an algorithm. The two
arguments are the driver and algorithm identifiers, respectively. Typically,
drivers for PCMCIA crypto cards that are being ejected will invoke this
routine for all algorithms supported by the card.
crypto_unregister_all
()
will unregister all algorithms registered by a driver and the driver will be
disabled (no new sessions will be allocated on that driver, and any existing
sessions will be migrated to other drivers). The same will be done if all
algorithms associated with a driver are unregistered one by one. After a
call to crypto_unregister_all
() there will be no
threads in either the newsession or freesession function of the driver.
The calling convention for the driver-supplied routines are:
- int
(*newsession)
(device_t, crypto_session_t, struct cryptoini *); - void
(*freesession)
(device_t, crypto_session_t); - int
(*process)
(device_t, struct cryptop *, int); - int
(*kprocess)
(device_t, struct cryptkop *, int);
On invocation, the first argument to
all routines is the device_t that was provided to
crypto_get_driverid
().
The second argument to
newsession
()
is the opaque session handle for the new session. The third argument is
identical to that of crypto_newsession
().
Drivers obtain a pointer to their
session memory by invoking
crypto_get_driver_session
()
on the opaque crypto_session_t handle.
The
freesession
()
routine takes as arguments the opaque data value and the session handle. It
should clear any context associated with the session (clear hardware
registers, memory, etc.). If no resources need to be released other than the
contents of session memory, the method is optional. The
crypto
framework will zero and release the allocated
session memory (after running the freesession
()
method, if one exists).
The
process
()
routine is invoked with a request to perform crypto processing. This routine
must not block or sleep, but should queue the request and return immediately
or process the request to completion. In case of an unrecoverable error, the
error indication must be placed in the crp_etype field
of the cryptop structure. When the request is
completed, or an error is detected, the process
()
routine must invoke crypto_done
(). Session migration
may be performed, as mentioned previously.
In case of a temporary resource exhaustion, the
process
()
routine may return ERESTART
in which case the crypto
services will requeue the request, mark the driver as
“blocked”, and stop submitting requests for processing. The
driver is then responsible for notifying the crypto services when it is
again able to process requests through the
crypto_unblock
()
routine. This simple flow control mechanism should only be used for
short-lived resource exhaustion as it causes operations to be queued in the
crypto layer. Doing so is preferable to returning an error in such cases as
it can cause network protocols to degrade performance by treating the
failure much like a lost packet.
The
kprocess
()
routine is invoked with a request to perform crypto key processing. This
routine must not block, but should queue the request and return immediately.
Upon processing the request, the callback routine should be invoked. In case
of an unrecoverable error, the error indication must be placed in the
krp_status field of the cryptkop
structure. When the request is completed, or an error is detected, the
kprocess
() routine should invoked
crypto_kdone
().
RETURN VALUES¶
crypto_register
(),
crypto_kregister
(),
crypto_unregister
(),
crypto_newsession
(),
crypto_freesession
(), and
crypto_unblock
() return 0 on success, or an error
code on failure. crypto_get_driverid
() returns a
non-negative value on error, and -1 on failure.
crypto_getreq
() returns a pointer to a
cryptop structure and NULL
on
failure. crypto_dispatch
() returns
EINVAL
if its argument or the callback function was
NULL
, and 0 otherwise. The callback is provided with
an error code in case of failure, in the crp_etype
field.
FILES¶
- sys/opencrypto/crypto.c
- most of the framework code
SEE ALSO¶
HISTORY¶
The cryptographic framework first appeared in
OpenBSD 2.7 and was written by
Angelos D. Keromytis
<angelos@openbsd.org>.
BUGS¶
The framework currently assumes that all the algorithms in a
crypto_newsession
() operation must be available by
the same driver. If that is not the case, session initialization will
fail.
The framework also needs a mechanism for determining which driver is best for a specific set of algorithms associated with a session. Some type of benchmarking is in order here.
Multiple instances of the same algorithm in the same session are not supported.
December 17, 2019 | Debian |