table of contents
TX(4) | Device Drivers Manual | TX(4) |
NAME¶
tx
— SMC 83c17x
Fast Ethernet device driver
SYNOPSIS¶
To compile this driver into the kernel, place the following lines in your kernel configuration file:
device miibus
device tx
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
if_tx_load="YES"
DEPRECATION NOTICE¶
The tx
driver is not present in
FreeBSD 13.0 and later. See
https://github.com/freebsd/fcp/blob/master/fcp-0101.md for more
information.
DESCRIPTION¶
The tx
driver provides support for the
Ethernet adapters based on the SMC 83c17x (EPIC) chips. These are mostly SMC
9432 series cards.
The tx
driver supports the following media
types (depending on card's capabilities):
autoselect
- Enable autonegotiation (default).
100baseFX
- Set 100Mbps (Fast Ethernet) fiber optic operation.
100baseTX
- Set 100Mbps (Fast Ethernet) twisted pair operation.
10baseT/UTP
- Set 10Mbps on 10baseT port.
10base2/BNC
- Set 10Mbps on 10base2 port.
The tx
driver supports the following media
options:
full-duplex
- Set full-duplex operation.
The tx
driver supports oversized Ethernet
packets (up to 1600 bytes). Refer to the ifconfig(8) man
page on setting the interface's MTU.
The old “ifconfig tx0 linkN
”
method of configuration is not supported.
VLAN (IEEE 802.1Q) support¶
The tx
driver supports the VLAN operation
(using vlan(4) interfaces) without decreasing the MTU on
the vlan(4) interfaces.
DIAGNOSTICS¶
- tx%d: device timeout %d packets
- The device stops responding. Device and driver reset follows this error.
- tx%d: PCI fatal error occurred (%s)
- One of following errors occurred: PCI Target Abort, PCI Master Abort, Data Parity Error or Address Parity Error. Device and driver reset follows this error.
- tx%d: cannot allocate mbuf header/cluster
- Cannot allocate memory for received packet. Packet thrown away.
- tx%d: can't stop %s DMA
- While resetting, the driver failed to stop the device correctly.
SEE ALSO¶
BUGS¶
The auto-negotiation does not work very well.
October 24, 2018 | Debian |