table of contents
LE(4) | Device Drivers Manual | LE(4) |
NAME¶
le
— AMD Am7900
LANCE and Am79C9xx ILACC/PCnet Ethernet interface driver
SYNOPSIS¶
To compile this driver into the kernel, place the following line in your kernel configuration file:
device le
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
if_le_load="YES"
For C-Bus non-PnP adapters, the port address and the IRQ number
have to be specified in /boot/device.hints:
hint.le.0.at="isa"
hint.le.0.port="0x03d0"
hint.le.0.irq="6"
For ISA non-PnP adapters, the port address as well as the IRQ and
the DRQ numbers have to be specified in
/boot/device.hints:
hint.le.0.at="isa"
hint.le.0.port="0x280"
hint.le.0.irq="10"
hint.le.0.drq="0"
DESCRIPTION¶
The le
driver provides support for
Ethernet adapters based on the AMD Am7990 and Am79C90 (CMOS, pin-compatible)
Local Area Network Controller for Ethernet (LANCE) chips.
The le
driver also supports Ethernet
adapters based on the AMD Am79C900 Integrated Local Area Communications
Controller (ILACC) as well as the Am79C9xx PCnet family of chips, which are
single-chip implementations of a LANCE chip and a DMA engine. This includes
a superset of the PCI bus Ethernet chips supported by the
pcn(4) driver. The le
driver
treats all of these PCI bus Ethernet chips as an AMD Am79C970 PCnet-PCI and
does not support the additional features like the MII bus and burst mode of
AMD Am79C971 PCnet-FAST and greater chips. Thus the pcn(4)
driver should be preferred for the latter.
Generally, the le
driver aims at
supporting as many different chips on as many different platforms as
possible, partially at the cost of the best performance with some of
these.
The le
driver supports reception and
transmission of extended frames for vlan(4). Selective
reception of multicast Ethernet frames is provided by a 64-bit mask;
multicast destination addresses are hashed to a bit entry using the Ethernet
CRC function.
HARDWARE¶
C-Bus and ISA¶
The le
driver supports C-Bus and ISA bus
Ethernet adapters which are based on the following chips:
- AMD Am7990 and Am79C90 LANCE
- AMD Am79C960 PCnet-ISA
- AMD Am79C961 PCnet-ISA+
- AMD Am79C961A PCnet-ISA II
This includes support for the following Ethernet adapters:
C-Bus non-PnP:
- Contec C-NET(98)S
ISA non-PnP:
- BICC Isolan
- Novell NE2100
ISA PnP:
- AMD AM1500T/AM2100
- AMD PCnet-32
- AMD PCnet-ISA
- Allied Telesyn AT-1500
- Boca LANCard Combo
- Cabletron E2100 Series DNI
- Cabletron E2200 Single Chip
- Melco Inc. LGY-IV
- Novell NE2100
- Racal InterLan EtherBlaster
The le
driver does not support the
selection of media types and options via ifconfig(8) with
C-Bus and ISA bus Ethernet adapters.
PCI¶
The PCI bus Ethernet chips supported by the
le
driver are:
- AMD Am53C974/Am79C970/Am79C974 PCnet-PCI
- AMD Am79C970A PCnet-PCI II
- AMD Am79C971 PCnet-FAST
- AMD Am79C972 PCnet-FAST+
- AMD Am79C973/Am79C975 PCnet-FAST III
- AMD Am79C976 PCnet-PRO
- AMD Am79C978 PCnet-Home
This includes support for the following Ethernet adapters:
- AcerLAN NIC P20
- Allied Telesyn AT-2450 and AT-2700 series
- VMware emulated AMD Am79C970A PCnet-PCI II interface
The le
driver supports the selection of
the following media types via ifconfig(8) with PCI bus
Ethernet adapters:
autoselect
- Enable autoselection of the media type.
10baseT/UTP
- Select UTP media.
10base5/AUI
- Select AUI/BNC media.
The following media option is supported with these media types:
full-duplex
- Select full duplex operation.
Note that unlike the pcn(4) driver, the
le
driver does not support selecting 100Mbps (Fast
Ethernet) media types.
sparc64¶
The le
driver supports the on-board LANCE
interfaces found in Sun Ultra 1 machines. The le
driver allows the selection of the following media types via
ifconfig(8) with these on-board interfaces:
autoselect
- Enable autoselection of the media type.
10baseT/UTP
- Select UTP media.
10base5/AUI
- Select AUI media.
When using autoselection, a default media type is selected for use by examining all ports for carrier. The first media type with which a carrier is detected will be selected. Additionally, if carrier is dropped on a port, the driver will switch between the possible ports until one with carrier is found.
The le
driver also supports the following
Sun SBus Ethernet add-on adapters:
- SCSI HBA and Buffered Ethernet (SBE/S, P/N 501-1869)
- Fast SCSI and Buffered Ethernet (FSBE/S, P/N 501-2015 and 501-2981)
The le
driver does not support the
selection of media types and options via ifconfig(8) with
SBus Ethernet add-on adapters.
For further information on configuring media types and options, see ifconfig(8).
DIAGNOSTICS¶
- le%d: overflow
- More packets came in from the Ethernet than there was space in the LANCE receive buffers. Packets were missed.
- le%d: receive buffer error
- The LANCE ran out of buffer space, packet dropped.
- le%d: lost carrier
- The Ethernet carrier disappeared during an attempt to transmit. The LANCE will finish transmitting the current packet, but will not automatically retry transmission if there is a collision.
- le%d: excessive collisions, tdr %d
- The Ethernet was extremely busy or jammed, outbound packets were dropped
after 16 attempts to retransmit.
TDR is the abbreviation of "Time Domain Reflectometry". The optionally reported TDR value is an internal counter of the interval between the start of a transmission and the occurrence of a collision. This value can be used to determine the distance from the Ethernet tap to the point on the Ethernet cable that is shorted or open (unterminated).
- le%d: dropping chained buffer
- A packet did not fit into a single receive buffer and was dropped. Since
the
le
driver allocates buffers large enough to receive maximum sized Ethernet packets, this means some other station on the LAN transmitted a packet larger than allowed by the Ethernet standard. - le%d: transmit buffer error
- The LANCE ran out of buffer space before finishing the transmission of a packet. If this error occurs, the driver software has a bug.
- le%d: underflow
- The LANCE ran out of buffer space before finishing the transmission of a packet. If this error occurs, the driver software has a bug.
- le%d: controller failed to initialize
- Driver failed to start the LANCE. This is potentially a hardware failure.
- le%d: memory error
- RAM failed to respond within the timeout when the LANCE wanted to read or write it. This is potentially a hardware failure.
- le%d: receiver disabled
- The receiver of the LANCE was turned off due to an error.
- le%d: transmitter disabled
- The transmitter of the LANCE was turned off due to an error.
SEE ALSO¶
altq(4), arp(4), intro(4), netintro(4), pcn(4), vlan(4), ifconfig(8)
HISTORY¶
The le
driver was ported from
NetBSD and first appeared in
FreeBSD 6.1. The NetBSD
version in turn was derived from the le
driver which
first appeared in 4.4BSD.
AUTHORS¶
The le
driver was ported by
Marius Strobl
<marius@FreeBSD.org>.
January 20, 2007 | Debian |