Scroll to navigation

UATH(4) Device Drivers Manual UATH(4)

NAME

uathAtheros USB IEEE 802.11a/b/g wireless network device

SYNOPSIS

To compile this driver into the kernel, place the following lines in your kernel configuration file:

device ehci
device uhci
device ohci
device usb
device uath
device wlan

Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):

if_uath_load="YES"

DESCRIPTION

The uath driver supports USB 2.0 wireless network devices based on Atheros Communications fifth generation AR5005UG and AR5005UX chipsets.

The AR5005UG chipset is made of an AR5523 multiprotocol MAC/baseband processor and an AR2112 Radio-on-a-Chip that can operate between 2300 and 2500 MHz (802.11b/g).

The AR5005UX chipset is made of an AR5523 multiprotocol MAC/baseband processor and an AR5112 dual band Radio-on-a-Chip that can operate between 2300 and 2500 MHz (802.11b/g) or 4900 and 5850 MHz (802.11a).

The AR5005UG and AR5005UX chipsets both have an integrated 32-bit MIPS R4000-class processor that runs a firmware and manages, among other things, the automatic control of the transmit rate and the calibration of the radio.

uath supports station, and monitor mode operation. Only one virtual interface may be configured at any time. For more information on configuring this device, see ifconfig(8).

FIRMWARE

uath requires firmware that is downloaded to the device. This is normally done by the uathload(8) utility that is launched by devd(8) when the device is inserted. uathload includes the firmware in the binary program. This firmware is licensed for general use and is included in the base system.

HARDWARE

The uath driver should work with the following adapters:

AR5005UX
AR5005UG
AR5005UG
AR5005UX
AR5005UG
AR5005UX
AR5005UG
AR5005UG
AR5005UX
AR5005UG
AR5005UG
AR5005UG
AR5005UX
AR5005UG
AR5005UX
AR5005UX
AR5005UX

An up to date list can be found at http://customerproducts.atheros.com/customerproducts/default.asp.

EXAMPLES

Join an existing BSS network (i.e., connect to an access point):

ifconfig wlan create wlandev uath0 inet 192.168.0.20 \
    netmask 0xffffff00

Join a specific BSS network with network name “my_net”:

ifconfig wlan create wlandev uath0 ssid my_net up

Join a specific BSS network with 64-bit WEP encryption:

ifconfig wlan create wlandev uath0 ssid my_net \
	wepmode on wepkey 0x1234567890 weptxkey 1 up

Join a specific BSS network with 128-bit WEP encryption:

ifconfig wlan create wlandev uath0 wlanmode adhoc ssid my_net \
    wepmode on wepkey 0x01020304050607080910111213 weptxkey 1

DIAGNOSTICS

uath%d: could not send command (error=%s)
An attempt to send a command to the firmware failed.
uath%d: timeout waiting for command reply
A read command was sent to the firmware but the firmware failed to reply in time.
uath%d: device timeout
A frame dispatched to the hardware for transmission did not complete in time. The driver will reset the hardware. This should not happen.

SEE ALSO

netintro(4), usb(4), wlan(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), devd(8), ifconfig(8), uathload(8), wpa_supplicant(8)

HISTORY

The uath driver first appeared in OpenBSD 4.0.

AUTHORS

The uath driver was written by Weongyo Jeong <weongyo@FreeBSD.org> and Sam Leffler <sam@FreeBSD.org>. It is distantly related to a driver written by Damien Bergamini <damien@openbsd.org>.

CAVEATS

Atheros proprietary 108 Mbps mode (aka Super AG mode) is not supported.

Dual-band adapters are presently not working; to workaround, restriction operation to 2.4GHz channels.

April 7, 2009 Debian