table of contents
AT45D(4) | Device Drivers Manual | AT45D(4) |
NAME¶
at45d
— driver for
DataFlash(tm) non-volatile storage devices
SYNOPSIS¶
To compile this driver into the kernel, place the following line in your kernel configuration file:
device at45d
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
at45d_load="YES"
DESCRIPTION¶
The at45d
driver provides support for the
family of non-volatile storage devices known collectively as DataFlash(tm).
DataFlash chips typically have part numbers beginning with AT45DB. The
at45d
driver supports only the SPI bus versions of
each AT45DB device, indicated by the last digit of the part number being 1
or 2.
The at45d
driver uses opcode 0x9f to read
the manufacturer and device ID data to determine whether the device is
supported. The device ID is looked up using a table of data within the
driver which describes the attributes of each supported device, such as
block size, sector size, and device capacity. When a supported device is
found, the at45d
driver creates a disk device and
makes it accessible at /dev/flash/at45d?. The new
disk device is then tasted by the available geom(4)
modules as with any disk device.
HARDWARE¶
The at45d
driver provides support for the
following devices:
- AT45DB011B
- AT45DB021B
- AT45DB041x
- AT45DB081B
- AT45DB161x
- AT45DB321x
- AT45DB321x
- AT45DB641E
- AT45DB642x
FDT CONFIGURATION¶
On an fdt(4) based system, the
at45d
device is defined as a slave device subnode of
the SPI bus controller node. All properties documented in the
spibus.txt bindings document can be used with the
at45d
device. The most commonly-used ones are
documented below.
The following properties are required in the
at45d
device subnode:
- compatible
- Must be the string "atmel,at45".
- reg
- Chip select address of device.
- spi-max-frequency
- The maximum bus frequency to use when communicating with this slave device. Actual bus speed may be lower, depending on the capabilities of the SPI bus controller hardware.
The following properties are optional for the
at45d
device subnode:
- freebsd,sectorsize
- The sector size of the disk created for this storage device. It must be a multiple of the device's page size. The default is the device page size.
- spi-cpha
- Empty property indicating the slave device requires shifted clock phase (CPHA) mode.
- spi-cpol
- Empty property indicating the slave device requires inverse clock polarity (CPOL) mode.
- spi-cs-high
- Empty property indicating the slave device requires chip select active high.
HINTS CONFIGURATION¶
On a device.hints(5) based system, such as
MIPS
, these values are configurable for
at45d
:
- hint.at45d.%d.at
- The spibus the
at45d
instance is attached to. - hint.at45d.%d.clock
- The maximum bus frequency to use when communicating with this device. Actual bus speed may be lower, depending on the capabilities of the SPI bus controller hardware.
- hint.at45d.%d.cs
- The chip-select number to assert when performing I/O for this device. Set the high bit (1 << 31) to invert the logic level of the chip select line.
- hint.at45d.%d.mode
- The SPI mode (0-3) to use when communicating with this device.
- hint.at45d.%d.sectorsize
- The sector size of the disk created for this storage device. It must be a multiple of the device's page size. The default is the device page size.
FILES¶
- /dev/flash/at45d?
- Provides read/write access to the storage device.
- /dev/flash/spi?
- An alias for the /dev/at45d? device, for backwards compatibility with older versions of the driver.
SEE ALSO¶
HISTORY¶
The at45d
driver first appeared in
FreeBSD 6.0.
March 2, 2019 | Debian |