table of contents
| SNMPTLS(1) | Net-SNMP | SNMPTLS(1) |
NAME¶
NET-SNMP - manage certificates for SNMP
SYNOPSIS¶
snmptls [APPLICATION OPTIONS] [COMMON OPTIONS] AGENT COMMAND [COMMAND OPTIONS]
USAGE: snmptls [-Cm mapTypeOID] [-Cd data] [-Cs storageType] [OPTIONS] AGENT<command> [command options]
DESCRIPTION¶
TBD snmptls is a tool to manage TLS certificates. These certificates are required when you are using SNMP over TLS or DTLS and are using TLS Transport Model (TLSTM) instead of User-based Security Model (USM).. These certificates are then mapped to SNMPv3 security names.
APPLICATION OPTIONS¶
- -Cm maptype
- Specify what field of the certificate will be used to map to the SNMPv3
security names. The names and definitions of these options come from
RFC 6563.
snmpTlstmCertCommonName CommonName snmpTlstmCertSANRFC822Name subjectAltName's rfc822Name snmpTlstmCertSANIpAddress subjectAltName's iPAddress snmpTlstmCertSANDNSName subjectAltName's dNSName snmpTlstmCertSpecified Specify the username
The default is snmpTlstmCertSpecified which means the mapped SNMPv3 security name will need to be specified with the -Cd option.
- -Cd
- SNMPv3 security name that this certificate is for.
- -Cs
- The storage type, as defined in RFC 2579. The default is nonVolatile.
COMMANDS¶
- certToSecName add PRIORITY HASHTYPE FINGERPRINT
- Add the given certificate to the remote agent. PRIORITY is an Usigned32 with lower numbers having higher priority. The FINGERPRINT is a cryptographic hash of the X.509 certificate, with the type of hash defined by HASHTYPE described in RFC 5246.
- targetParamsFingerprint add PARAMS-NAME HASHTYPE FINGERPRINT
- TBD
- targetAddr add TARGET-NAME HASHTYPE [HASHTYPE REMOTE-FINGERPRINT] [SERVER-IDENTITY]
- TBD
SEE ALSO¶
| 2026-09-10 | x |