- unstable 4.32.4-1
| MUTT(1) | Manuel de l'utilisateur | MUTT(1) |
NOM¶
mutt – Agent de messagerie Mutt
SYNOPSIS¶
- mutt
- [-nRyzZ] [-e commande] [-F fichierrc] [-m type] [-f boîte_aux_lettres]
- mutt
- [-Enx] [-e commande] [-F fichierrc]
[-H brouillon] [-i inclusion]
[-b adresse_copie_cachée] [-c adresse_copie] [-s sujet]
[-a fichier ... --] adresse_destinataire ... - mutt
- [-nx] [-e commande] [-F fichierrc]
[-b adresse_copie_cachée] [-c
adresse_copie]
[-s sujet] [-a fichier ... --] adresse_destinataire ... < message - mutt
- [-n] [-e commande] [-F fichierrc] -p
- mutt
- [-n] [-e commande] [-F fichierrc] -A alias
- mutt
- [-n] [-e commande] [-F fichierrc] -Q variable
- mutt
- -v[v]
- mutt
- -D
DESCRIPTION¶
mutt est programme textuel très petit mais très puissant pour lire et envoyer des courriels pour des systèmes UNIX, incluant la prise en charge de la couleur pour les terminaux, de MIME, d’OpenPGP et un mode de tri multifil.
Remarque : cette page de manuel donne un bref aperçu des options de ligne de commande de l’exécutable mutt. Une copie du manuel entier est dans le dossier /usr/share/doc/mutt, aux formats texte, HTML ou PDF. Veuillez vous référer à ce manuel pour configurer et utiliser mutt.
OPTIONS¶
- -A alias
- Afficher une version développée de l’alias spécifié et quitter.
- -a fichier ...
- Joindre un fichier en se servant de MIME. Séparer
fichier des arguments adresse_destinataire avec
« -- » est obligatoire. Par
exemple :
mutt -a image.jpg -- adresse_destinataire mutt -a img.jpg *.png -- adresse_destinataire1 adresse_destinataire2
L’option -a doit être placée à la fin des options de la ligne de commande.
- -b addr-Bcc
- Spécifier une adresse de copie cachée (Bcc).
- -c adresse_copie
- Spécifier une adresse de copie (Cc).
- -d niveau
- Si mutt a été compilé avec +DEBUG, le journal de débogage est écrit dans ~/.muttdebug0. niveau peut varier de -5 à 5 et change la prolixité. Une valeur zéro désactive le débogage. Une valeur inférieure à zéro désactive la rotation automatique des journaux. Le niveau est alors la valeur absolue de cette valeur. Une valeur 2 (-2) est recommandée pour la plupart des diagnostics.
- -D
- Afficher la valeur de toutes les options de configuration sur la sortie standard.
- -E
- Éditer le fichier brouillon spécifié avec l’option -H ou le fichier inclusion spécifié avec l’option -i lors de la composition du message.
- -e commande
- Spécifier une commande de configuration à exécuter après le traitement des fichiers d’initialisation.
- -f boîte_aux_lettres
- Spécifier une boîte_aux_lettres à charger.
- -F fichierrc
- Utiliser fichierrc comme fichier de configuration de l’utilisateur.
- -h
- Afficher un court message d'aide et terminer.
- -H brouillon
- Spécifier un fichier brouillon qui contient l’entête et le corps du message à envoyer. Si brouillon est « - », les données sont lues depuis l’entrée standard. Le fichier de brouillon ne doit contenir qu’un courriel de style RFC822 — entêtes et corps. Bien que ce ne soit pas un fichier mbox(5), si une ligne mbox « From » est présente, elle est supprimée sans avertissement. Les fichiers de brouillon sont traités de la même manière dans les modes interactifs et par lots. Ils ne sont pas passés tels quels. Par exemple, les fichiers de brouillon chiffrés sont déchiffrés.
- -i inclusion
- Spécifier un fichier inclusion à insérer dans le corps du message. Il est ignoré si l’option -H est passée. Si inclusion est « - », les données sont lues depuis l’entrée standard.
- -m type
- Spécifier un type de boîte aux lettres par défaut pour les répertoires nouvellement créés. Ce peut être un des suivants : mbox, MMDF, MH ou Maildir. Voir aussi $mbox_type dans le manuel.
- -n
- Ne pas lire le fichier de configuration muttrc global au système.
- -p
- Reprendre un message différé. Quitter immédiatement en l’absence de message.
- -Q variable
- Rechercher une variable de configuration. La recherche est réalisée après que tous les fichiers de configuration ont été analysés et que toute commande indiquée a été exécutée.
- -R
- Ouvrir une boîte aux lettres en mode lecture seule.
- -s sujet
- Spécifier le sujet du message. Il doit être entouré de guillemets s’il contient des espaces.
- -v
- Afficher le numéro de version de mutt et les définitions au moment de la compilation.
- -vv
- Afficher les informations de licence et de droits d’auteur.
- -x
- Émuler le mode de composition de mailx(1).
- -y
- Démarrer mutt avec une liste de toutes les boîtes aux lettres spécifiées avec la commande de configuration de boîte aux lettres.
- -z
- Quitter immédiatement avec le code 1 si une boîte_aux_lettres spécifiée avec l’option -f ne contient aucun message.
- -Z
- Ouvrir la première boîte aux lettres spécifiée par la commande de configuration de boîte_aux_lettres qui contient un nouveau courriel. Quitter immédiatement avec le code 1 si aucun nouveau message n’est présent dans toutes les boîtes aux lettres.
- --
- Traiter les arguments restants en tant que adresse_destinataire même s’ils débutent avec un tiret. Consulter aussi l’option -a ci-avant. adresse_destinataire peut être une adresse locale de courriel ou une adresse réseau de courriel, ainsi qu’un URL d’adresse de destination (mailto:).
ENVIRONNEMENT¶
- EDITOR, VISUAL
- Spécification de l’éditeur à utiliser pour la composition des messages. Si les variables d’environnement EDITOR et VISUAL sont définies, cette dernière a la priorité. Si aucune n’est définie, la valeur par défaut est vi.
- EGDSOCKET, RANDFILE
- Chemins utilisés pour initialiser le générateur de nombres aléatoires pour la bibliothèque SSL.
- L’adresse de courriel de l’utilisateur.
- DÉBUT
- Chemin complet du répertoire personnel de l’utilisateur.
- Chemin complet de la boîte aux lettres de file d’attente (spool) de l’utilisateur.
- MAILDIR
- Chemin complet de la boîte aux lettres de file d’attente (spool) de l’utilisateur si MAIL n’est pas définie, généralement utilisé lorsque la boîte aux lettres de file d'attente est un dossier maildir(5).
- MAILCAPS
- Chemin de recherche des fichiers mailcap(5).
- MM_NOASK
- Si cette variable est définie, mailcap sera toujours utilisé sans invite.
- PGPPATH
- Répertoire dans lequel trouver le trousseau de clés publiques PGP de l’utilisateur. Lors de leur utilisation avec le programme PGP original, mutt et mutt_pgpring(1) reposent sur sa définition.
- REPLYTO
- Adresse de réponse par défaut.
- TMPDIR
- Répertoire des fichiers temporaires. Si non défini, /tmp est utilisé pour $tmpdir et /var/tmp est utilisé pour $tmpdraftdir. Consulter aussi les variables de configuration $tmpdir et $tmpdraftdir.
- LC_ALL, LC_CTYPE, LANG
- Détermination du jeu de caractères et des paramètres régionaux à utiliser.
- TEXTDOMAINDIR
- Répertoire contenant les fichiers de traduction. Si défini, ce chemin outrepasse celui du répertoire d’installation de mutt et est utilisé pour des tests de modifications de traduction.
FICHIERS¶
- ~/.muttrc
- ~/.mutt/muttrc
- $XDG_CONFIG_HOME/mutt/muttrc
- Fichiers de configuration de l'utilisateur.
- /etc/Muttrc ou /usr/share/mutt/Muttrc
- Fichier de configuration système.
- /tmp/muttXXXXXX
- Fichiers temporaires créés par Mutt
- ~/.muttdebug0
- Fichier contenant la sortie de débogage. mutt effectue automatiquement une rotation des fichiers de journal en modifiant le numéro à la fin. Consulter l’option -d ci-avant.
- ~/.mailcap
- Définition pour l’utilisateur pour la gestion des types MIME autres que texte.
- /etc/mailcap
- Définition pour le système pour la gestion des types MIME autres que texte.
- ~/.mime.types
- Mappage personnel de l’utilisateur entre les types MIME et les extensions de fichier.
- /etc/mime.types
- Mappage du système entre les types MIME et les extensions de fichier.
- /usr/bin/mutt_dotlock
- Programme de verrouillage (dotlock) privilégié.
- /usr/share/doc/mutt/manual.txt.gz
- Le manuel de mutt.
BOGUES¶
Aucun. mutt peut présenter des problèmes mineurs mais n’a pas de problèmes majeurs.
INCOMPATIBILITÉS¶
Suspendre/reprendre lors de l’édition d’un fichier avec un éditeur externe ne fonctionne pas sous SunOS 4.x si la bibliothèque curses est dans /usr/5lib. Cependant, cela devrait fonctionner avec la bibliothèque S-Lang.
Redimensionner l’écran lors de l’utilisation d’un pageur externe fait que mutt devient chaotique sur certains systèmes.
Suspendre/reprendre ne fonctionne pas sous Ultrix.
La ligne d’aide pour le menu d’index n’est pas mise à jour lors des changements de liaison d’une des fonctions listées quand mutt est en cours d’exécution.
Pour une liste plus actualisée des bogues, des messages d’erreur, des incompatibilités, veuillez consulter le système de suivi des bogues du projet dans la page https://gitlab.com/muttmua/mutt/issues. REMARQUE : le système de suivi des bogues n’est pas destiné à recevoir des requêtes de fonctionnalité. Elles doivent être adressées à la liste de diffusion mutt-dev (voir la section 1.2 du manuel pour plus de détails).
ABSENCE DE GARANTIE¶
Ce programme est distribué dans l'espoir qu'il sera utile, mais SANS AUCUNE GARANTIE, sans même une garantie implicite de COMMERCIALITÉ ou DE CONFORMITÉ A UNE UTILISATION PARTICULIÈRE. Voir la Licence Publique Générale GNU pour plus de détails.
VOIR AUSSI¶
mutt_dotlock(1), mutt_pgpring(1), pgpewrap(1), sendmail(1), smail(1), smime_keys(1), curses(3), ncurses(3), mailcap(5), maildir(5), mbox(5), mmdf(5), muttrc(5)
Page d’accueil de Mutt : http://www.mutt.org/
Le manuel de Mutt
RFC5322 — Format de message d’Internet : https://tools.ietf.org/rfcmarkup/5322 (RFC2822 et RFC822 obsolètes)
AUTEUR¶
Michael Elkins et d’autres. Utiliser <mutt-dev@mutt.org> pour contacter les développeurs.
TRADUCTION¶
La traduction française de cette page de manuel a été créée par Jean-Paul Guillonneau <guillonneau.jeanpaul@free.fr>
Cette traduction est une documentation libre ; veuillez vous reporter à la GNU General Public License version 3 concernant les conditions de copie et de distribution. Il n'y a aucune RESPONSABILITÉ LÉGALE.
Si vous découvrez un bogue dans la traduction de cette page de manuel, veuillez envoyer un message à debian-l10n-french@lists.debian.org.
| 24 juillet 2020 | Unix |